Only install the specific version of postgis we want
authorTom Hughes <tom@compton.nu>
Fri, 1 Nov 2019 08:46:20 +0000 (08:46 +0000)
committerTom Hughes <tom@compton.nu>
Fri, 1 Nov 2019 08:47:13 +0000 (08:47 +0000)
This stops new versions of postgis, and via dependency, of postgres
from getting installed automatically.

cookbooks/nominatim/recipes/default.rb
cookbooks/tile/recipes/default.rb

index 47b52274fd63be22fd455916c818b1054df02d6e..63fe2ca0662c8ecd9a15fcdbf66650bbfa988337 100644 (file)
@@ -55,7 +55,6 @@ include_recipe "postgresql"
 postgresql_version = node[:nominatim][:dbcluster].split("/").first
 postgis_version = node[:nominatim][:postgis]
 
-package "postgis"
 package "postgresql-#{postgresql_version}-postgis-#{postgis_version}"
 
 node[:nominatim][:dbadmins].each do |user|
index ead3638aacb063c51f14cffedd0f579e7923eeb3..971e953840e08391b3e59c47fce193c86fd99d8b 100644 (file)
@@ -360,7 +360,6 @@ end
 postgresql_version = node[:tile][:database][:cluster].split("/").first
 postgis_version = node[:tile][:database][:postgis]
 
-package "postgis"
 package "postgresql-#{postgresql_version}-postgis-#{postgis_version}"
 
 postgresql_user "jburgess" do