Update rubocop and fix new warnings