Update bundle
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.1)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.2)
8       actionpack (= 5.2.2)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.2)
12       actionpack (= 5.2.2)
13       actionview (= 5.2.2)
14       activejob (= 5.2.2)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.2)
18       actionview (= 5.2.2)
19       activesupport (= 5.2.2)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.2)
27       activesupport (= 5.2.2)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.2)
35       activesupport (= 5.2.2)
36       globalid (>= 0.3.6)
37     activemodel (5.2.2)
38       activesupport (= 5.2.2)
39     activerecord (5.2.2)
40       activemodel (= 5.2.2)
41       activesupport (= 5.2.2)
42       arel (>= 9.0)
43     activestorage (5.2.2)
44       actionpack (= 5.2.2)
45       activerecord (= 5.2.2)
46       marcel (~> 0.3.1)
47     activesupport (5.2.2)
48       concurrent-ruby (~> 1.0, >= 1.0.2)
49       i18n (>= 0.7, < 2)
50       minitest (~> 5.1)
51       tzinfo (~> 1.1)
52     addressable (2.6.0)
53       public_suffix (>= 2.0.2, < 4.0)
54     annotate (2.7.4)
55       activerecord (>= 3.2, < 6.0)
56       rake (>= 10.4, < 13.0)
57     arel (9.0.0)
58     ast (2.4.0)
59     autoprefixer-rails (8.6.5)
60       execjs
61     better_errors (2.5.0)
62       coderay (>= 1.0.0)
63       erubi (>= 1.0.0)
64       rack (>= 0.9.0)
65     bigdecimal (1.1.0)
66     binding_of_caller (0.8.0)
67       debug_inspector (>= 0.0.1)
68     bootsnap (1.3.2)
69       msgpack (~> 1.0)
70     builder (3.2.3)
71     cancancan (2.3.0)
72     canonical-rails (0.2.5)
73       rails (>= 4.1, < 6.1)
74     capybara (2.18.0)
75       addressable
76       mini_mime (>= 0.1.3)
77       nokogiri (>= 1.3.3)
78       rack (>= 1.0.0)
79       rack-test (>= 0.5.4)
80       xpath (>= 2.0, < 4.0)
81     climate_control (0.2.0)
82     cliver (0.3.2)
83     coderay (1.1.2)
84     coffee-rails (4.2.2)
85       coffee-script (>= 2.2.0)
86       railties (>= 4.0.0)
87     coffee-script (2.4.1)
88       coffee-script-source
89       execjs
90     coffee-script-source (1.12.2)
91     composite_primary_keys (11.1.0)
92       activerecord (~> 5.2.1)
93     concurrent-ruby (1.1.4)
94     coveralls (0.8.22)
95       json (>= 1.8, < 3)
96       simplecov (~> 0.16.1)
97       term-ansicolor (~> 1.3)
98       thor (~> 0.19.4)
99       tins (~> 1.6)
100     crack (0.4.3)
101       safe_yaml (~> 1.0.0)
102     crass (1.0.4)
103     dalli (2.7.9)
104     debug_inspector (0.0.3)
105     delayed_job (4.1.5)
106       activesupport (>= 3.0, < 5.3)
107     delayed_job_active_record (4.1.3)
108       activerecord (>= 3.0, < 5.3)
109       delayed_job (>= 3.0, < 5)
110     docile (1.3.1)
111     dynamic_form (1.1.4)
112     erubi (1.8.0)
113     execjs (2.7.0)
114     exifr (1.3.5)
115     factory_bot (4.11.1)
116       activesupport (>= 3.0.0)
117     factory_bot_rails (4.11.1)
118       factory_bot (~> 4.11.1)
119       railties (>= 3.0.0)
120     fakefs (0.18.1)
121     faraday (0.15.4)
122       multipart-post (>= 1.2, < 3)
123     ffi (1.9.25)
124     fspath (3.1.0)
125     gd2-ffij (0.3.0)
126       ffi (>= 1.0.0)
127     geoip (1.6.4)
128     globalid (0.4.2)
129       activesupport (>= 4.2.0)
130     hashdiff (0.3.8)
131     hashie (3.6.0)
132     htmlentities (4.3.4)
133     http_accept_language (2.0.5)
134     i18n (0.9.5)
135       concurrent-ruby (~> 1.0)
136     i18n-js (3.2.1)
137       i18n (>= 0.6.6)
138     image_optim (0.26.3)
139       exifr (~> 1.2, >= 1.2.2)
140       fspath (~> 3.0)
141       image_size (>= 1.5, < 3)
142       in_threads (~> 1.3)
143       progress (~> 3.0, >= 3.0.1)
144     image_optim_rails (0.4.1)
145       image_optim (~> 0.24)
146       rails
147       sprockets
148     image_size (2.0.0)
149     in_threads (1.5.1)
150     jaro_winkler (1.5.2)
151     jquery-rails (4.3.3)
152       rails-dom-testing (>= 1, < 3)
153       railties (>= 4.2.0)
154       thor (>= 0.14, < 2.0)
155     jshint (1.5.0)
156       execjs (>= 1.4.0)
157       multi_json (~> 1.0)
158       therubyracer (~> 0.12.1)
159     json (2.1.0)
160     jsonify (0.3.1)
161       multi_json (~> 1.0)
162     jsonify-rails (0.3.2)
163       actionpack
164       jsonify (< 0.4.0)
165     jwt (2.1.0)
166     kgio (2.11.2)
167     kramdown (2.0.0)
168     libv8 (3.16.14.19)
169     libxml-ruby (3.1.0)
170     listen (3.1.5)
171       rb-fsevent (~> 0.9, >= 0.9.4)
172       rb-inotify (~> 0.9, >= 0.9.7)
173       ruby_dep (~> 1.2)
174     logstash-event (1.2.02)
175     logstasher (1.3.0)
176       activesupport (>= 4.0)
177       logstash-event (~> 1.2.0)
178       request_store
179     loofah (2.2.3)
180       crass (~> 1.0.2)
181       nokogiri (>= 1.5.9)
182     mail (2.7.1)
183       mini_mime (>= 0.1.1)
184     marcel (0.3.3)
185       mimemagic (~> 0.3.2)
186     method_source (0.9.2)
187     mime-types (3.2.2)
188       mime-types-data (~> 3.2015)
189     mime-types-data (3.2018.0812)
190     mimemagic (0.3.3)
191     mini_mime (1.0.1)
192     mini_portile2 (2.4.0)
193     minitest (5.11.3)
194     msgpack (1.2.6)
195     multi_json (1.13.1)
196     multi_xml (0.6.0)
197     multipart-post (2.0.0)
198     nio4r (2.3.1)
199     nokogiri (1.10.1)
200       mini_portile2 (~> 2.4.0)
201     nokogumbo (2.0.1)
202       nokogiri (~> 1.8, >= 1.8.4)
203     oauth (0.4.7)
204     oauth-plugin (0.5.1)
205       multi_json
206       oauth (~> 0.4.4)
207       oauth2 (>= 0.5.0)
208       rack
209     oauth2 (1.4.1)
210       faraday (>= 0.8, < 0.16.0)
211       jwt (>= 1.0, < 3.0)
212       multi_json (~> 1.3)
213       multi_xml (~> 0.5)
214       rack (>= 1.2, < 3)
215     omniauth (1.9.0)
216       hashie (>= 3.4.6, < 3.7.0)
217       rack (>= 1.6.2, < 3)
218     omniauth-facebook (5.0.0)
219       omniauth-oauth2 (~> 1.2)
220     omniauth-github (1.3.0)
221       omniauth (~> 1.5)
222       omniauth-oauth2 (>= 1.4.0, < 2.0)
223     omniauth-google-oauth2 (0.6.0)
224       jwt (>= 2.0)
225       omniauth (>= 1.1.1)
226       omniauth-oauth2 (>= 1.5)
227     omniauth-mediawiki (0.0.4)
228       jwt (~> 2.0)
229       omniauth-oauth (~> 1.0)
230     omniauth-oauth (1.1.0)
231       oauth
232       omniauth (~> 1.0)
233     omniauth-oauth2 (1.6.0)
234       oauth2 (~> 1.1)
235       omniauth (~> 1.9)
236     omniauth-openid (1.0.1)
237       omniauth (~> 1.0)
238       rack-openid (~> 1.3.1)
239     omniauth-windowslive (0.0.12)
240       multi_json (~> 1.12)
241       omniauth-oauth2 (~> 1.4)
242     openstreetmap-deadlock_retry (1.3.0)
243     paperclip (5.3.0)
244       activemodel (>= 4.2.0)
245       activesupport (>= 4.2.0)
246       mime-types
247       mimemagic (~> 0.3.0)
248       terrapin (~> 0.6.0)
249     parallel (1.13.0)
250     parser (2.6.0.0)
251       ast (~> 2.4.0)
252     pg (0.21.0)
253     poltergeist (1.18.1)
254       capybara (>= 2.1, < 4)
255       cliver (~> 0.3.1)
256       websocket-driver (>= 0.2.0)
257     powerpack (0.1.2)
258     progress (3.5.0)
259     psych (3.1.0)
260     public_suffix (3.0.3)
261     puma (3.12.0)
262     quad_tile (1.0.1)
263     r2 (0.2.7)
264     rack (2.0.6)
265     rack-cors (1.0.2)
266     rack-openid (1.3.1)
267       rack (>= 1.1.0)
268       ruby-openid (>= 2.1.8)
269     rack-test (1.1.0)
270       rack (>= 1.0, < 3)
271     rack-uri_sanitizer (0.0.2)
272     rails (5.2.2)
273       actioncable (= 5.2.2)
274       actionmailer (= 5.2.2)
275       actionpack (= 5.2.2)
276       actionview (= 5.2.2)
277       activejob (= 5.2.2)
278       activemodel (= 5.2.2)
279       activerecord (= 5.2.2)
280       activestorage (= 5.2.2)
281       activesupport (= 5.2.2)
282       bundler (>= 1.3.0)
283       railties (= 5.2.2)
284       sprockets-rails (>= 2.0.0)
285     rails-controller-testing (1.0.4)
286       actionpack (>= 5.0.1.x)
287       actionview (>= 5.0.1.x)
288       activesupport (>= 5.0.1.x)
289     rails-dom-testing (2.0.3)
290       activesupport (>= 4.2.0)
291       nokogiri (>= 1.6)
292     rails-html-sanitizer (1.0.4)
293       loofah (~> 2.2, >= 2.2.2)
294     rails-i18n (4.0.2)
295       i18n (~> 0.6)
296       rails (>= 4.0)
297     railties (5.2.2)
298       actionpack (= 5.2.2)
299       activesupport (= 5.2.2)
300       method_source
301       rake (>= 0.8.7)
302       thor (>= 0.19.0, < 2.0)
303     rainbow (3.0.0)
304     rake (12.3.2)
305     rb-fsevent (0.10.3)
306     rb-inotify (0.10.0)
307       ffi (~> 1.0)
308     record_tag_helper (1.0.0)
309       actionview (~> 5.x)
310     ref (2.0.0)
311     request_store (1.4.1)
312       rack (>= 1.4)
313     rinku (2.0.4)
314     rotp (4.0.2)
315       addressable (~> 2.5)
316     rubocop (0.63.1)
317       jaro_winkler (~> 1.5.1)
318       parallel (~> 1.10)
319       parser (>= 2.5, != 2.5.1.1)
320       powerpack (~> 0.1)
321       rainbow (>= 2.2.2, < 4.0)
322       ruby-progressbar (~> 1.7)
323       unicode-display_width (~> 1.4.0)
324     ruby-openid (2.7.0)
325     ruby-progressbar (1.10.0)
326     ruby_dep (1.5.0)
327     safe_yaml (1.0.4)
328     sanitize (5.0.0)
329       crass (~> 1.0.2)
330       nokogiri (>= 1.8.0)
331       nokogumbo (~> 2.0)
332     sassc (2.0.0)
333       ffi (~> 1.9.6)
334       rake
335     sassc-rails (2.1.0)
336       railties (>= 4.0.0)
337       sassc (>= 2.0)
338       sprockets (> 3.0)
339       sprockets-rails
340       tilt
341     secure_headers (6.0.0)
342     simplecov (0.16.1)
343       docile (~> 1.1)
344       json (>= 1.8, < 3)
345       simplecov-html (~> 0.10.0)
346     simplecov-html (0.10.2)
347     sprockets (3.7.2)
348       concurrent-ruby (~> 1.0)
349       rack (> 1, < 3)
350     sprockets-rails (3.2.1)
351       actionpack (>= 4.0)
352       activesupport (>= 4.0)
353       sprockets (>= 3.0.0)
354     term-ansicolor (1.7.1)
355       tins (~> 1.0)
356     terrapin (0.6.0)
357       climate_control (>= 0.0.3, < 1.0)
358     therubyracer (0.12.3)
359       libv8 (~> 3.16.14.15)
360       ref
361     thor (0.19.4)
362     thread_safe (0.3.6)
363     tilt (2.0.9)
364     tins (1.20.2)
365     tzinfo (1.2.5)
366       thread_safe (~> 0.1)
367     uglifier (4.1.20)
368       execjs (>= 0.3.0, < 3)
369     unicode-display_width (1.4.1)
370     validates_email_format_of (1.6.3)
371       i18n
372     vendorer (0.2.0)
373     webmock (3.5.1)
374       addressable (>= 2.3.6)
375       crack (>= 0.3.2)
376       hashdiff
377     websocket-driver (0.7.0)
378       websocket-extensions (>= 0.1.0)
379     websocket-extensions (0.1.3)
380     xpath (3.2.0)
381       nokogiri (~> 1.8)
382
383 PLATFORMS
384   ruby
385
386 DEPENDENCIES
387   SystemTimer (>= 1.1.3)
388   aasm
389   actionpack-page_caching
390   active_record_union
391   annotate
392   autoprefixer-rails (~> 8.6.3)
393   better_errors
394   bigdecimal (~> 1.1.0)
395   binding_of_caller
396   bootsnap (>= 1.1.0)
397   cancancan
398   canonical-rails
399   capybara (~> 2.13)
400   coffee-rails (~> 4.2)
401   composite_primary_keys (~> 11.1.0)
402   coveralls
403   dalli
404   delayed_job_active_record
405   dynamic_form
406   factory_bot_rails
407   fakefs
408   faraday
409   gd2-ffij
410   geoip
411   htmlentities
412   http_accept_language (~> 2.0.0)
413   i18n-js (>= 3.0.0)
414   image_optim_rails
415   jquery-rails
416   jshint
417   json
418   jsonify-rails
419   kgio
420   kramdown
421   libxml-ruby (>= 2.0.5)
422   listen
423   logstasher
424   minitest (~> 5.1)
425   oauth-plugin (>= 0.5.1)
426   omniauth
427   omniauth-facebook
428   omniauth-github
429   omniauth-google-oauth2 (>= 0.6.0)
430   omniauth-mediawiki (>= 0.0.4)
431   omniauth-openid
432   omniauth-windowslive
433   openstreetmap-deadlock_retry (>= 1.3.0)
434   paperclip (~> 5.2)
435   pg (~> 0.18)
436   poltergeist
437   psych
438   puma (~> 3.7)
439   quad_tile (~> 1.0.1)
440   r2 (~> 0.2.7)
441   rack-cors
442   rack-uri_sanitizer
443   rails (= 5.2.2)
444   rails-controller-testing
445   rails-i18n (~> 4.0.0)
446   record_tag_helper
447   rinku (>= 1.2.2)
448   rotp
449   rubocop
450   sanitize
451   sassc-rails
452   secure_headers
453   uglifier (>= 1.3.0)
454   validates_email_format_of (>= 1.5.1)
455   vendorer
456   webmock
457
458 BUNDLED WITH
459    1.16.2