Update to rails 5.2.0
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (4.12.3)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.0)
8       actionpack (= 5.2.0)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.0)
12       actionpack (= 5.2.0)
13       actionview (= 5.2.0)
14       activejob (= 5.2.0)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.0)
18       actionview (= 5.2.0)
19       activesupport (= 5.2.0)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.0)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.0)
27       activesupport (= 5.2.0)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     activejob (5.2.0)
33       activesupport (= 5.2.0)
34       globalid (>= 0.3.6)
35     activemodel (5.2.0)
36       activesupport (= 5.2.0)
37     activerecord (5.2.0)
38       activemodel (= 5.2.0)
39       activesupport (= 5.2.0)
40       arel (>= 9.0)
41     activestorage (5.2.0)
42       actionpack (= 5.2.0)
43       activerecord (= 5.2.0)
44       marcel (~> 0.3.1)
45     activesupport (5.2.0)
46       concurrent-ruby (~> 1.0, >= 1.0.2)
47       i18n (>= 0.7, < 2)
48       minitest (~> 5.1)
49       tzinfo (~> 1.1)
50     addressable (2.5.2)
51       public_suffix (>= 2.0.2, < 4.0)
52     annotate (2.7.4)
53       activerecord (>= 3.2, < 6.0)
54       rake (>= 10.4, < 13.0)
55     arel (9.0.0)
56     ast (2.4.0)
57     autoprefixer-rails (8.6.3)
58       execjs
59     better_errors (2.4.0)
60       coderay (>= 1.0.0)
61       erubi (>= 1.0.0)
62       rack (>= 0.9.0)
63     bigdecimal (1.1.0)
64     binding_of_caller (0.8.0)
65       debug_inspector (>= 0.0.1)
66     bootsnap (1.3.0)
67       msgpack (~> 1.0)
68     builder (3.2.3)
69     canonical-rails (0.2.3)
70       rails (>= 4.1, < 5.3)
71     capybara (2.18.0)
72       addressable
73       mini_mime (>= 0.1.3)
74       nokogiri (>= 1.3.3)
75       rack (>= 1.0.0)
76       rack-test (>= 0.5.4)
77       xpath (>= 2.0, < 4.0)
78     climate_control (0.2.0)
79     cliver (0.3.2)
80     coderay (1.1.2)
81     coffee-rails (4.2.2)
82       coffee-script (>= 2.2.0)
83       railties (>= 4.0.0)
84     coffee-script (2.4.1)
85       coffee-script-source
86       execjs
87     coffee-script-source (1.12.2)
88     composite_primary_keys (11.0.0)
89       activerecord (~> 5.2.0)
90     concurrent-ruby (1.0.5)
91     coveralls (0.8.21)
92       json (>= 1.8, < 3)
93       simplecov (~> 0.14.1)
94       term-ansicolor (~> 1.3)
95       thor (~> 0.19.4)
96       tins (~> 1.6)
97     crack (0.4.3)
98       safe_yaml (~> 1.0.0)
99     crass (1.0.4)
100     dalli (2.7.8)
101     debug_inspector (0.0.3)
102     docile (1.1.5)
103     dynamic_form (1.1.4)
104     erubi (1.7.1)
105     execjs (2.7.0)
106     exifr (1.3.4)
107     factory_bot (4.10.0)
108       activesupport (>= 3.0.0)
109     factory_bot_rails (4.10.0)
110       factory_bot (~> 4.10.0)
111       railties (>= 3.0.0)
112     faraday (0.12.2)
113       multipart-post (>= 1.2, < 3)
114     ffi (1.9.25)
115     fspath (3.1.0)
116     geoip (1.6.4)
117     globalid (0.4.1)
118       activesupport (>= 4.2.0)
119     hashdiff (0.3.7)
120     hashie (3.5.7)
121     htmlentities (4.3.4)
122     http_accept_language (2.0.5)
123     i18n (0.9.5)
124       concurrent-ruby (~> 1.0)
125     i18n-js (3.0.8)
126       i18n (>= 0.6.6, < 2)
127     image_optim (0.26.1)
128       exifr (~> 1.2, >= 1.2.2)
129       fspath (~> 3.0)
130       image_size (~> 1.5)
131       in_threads (~> 1.3)
132       progress (~> 3.0, >= 3.0.1)
133     image_optim_rails (0.4.1)
134       image_optim (~> 0.24)
135       rails
136       sprockets
137     image_size (1.5.0)
138     in_threads (1.5.0)
139     jaro_winkler (1.5.1)
140     jquery-rails (4.3.3)
141       rails-dom-testing (>= 1, < 3)
142       railties (>= 4.2.0)
143       thor (>= 0.14, < 2.0)
144     jshint (1.5.0)
145       execjs (>= 1.4.0)
146       multi_json (~> 1.0)
147       therubyracer (~> 0.12.1)
148     json (2.1.0)
149     jsonify (0.3.1)
150       multi_json (~> 1.0)
151     jsonify-rails (0.3.2)
152       actionpack
153       jsonify (< 0.4.0)
154     jwt (1.5.6)
155     kgio (2.11.2)
156     libv8 (3.16.14.19)
157     libxml-ruby (3.1.0)
158     listen (3.1.5)
159       rb-fsevent (~> 0.9, >= 0.9.4)
160       rb-inotify (~> 0.9, >= 0.9.7)
161       ruby_dep (~> 1.2)
162     logstash-event (1.2.02)
163     logstasher (1.2.2)
164       activesupport (>= 4.0)
165       logstash-event (~> 1.2.0)
166       request_store
167     loofah (2.2.2)
168       crass (~> 1.0.2)
169       nokogiri (>= 1.5.9)
170     mail (2.7.0)
171       mini_mime (>= 0.1.1)
172     marcel (0.3.2)
173       mimemagic (~> 0.3.2)
174     method_source (0.9.0)
175     mime-types (3.1)
176       mime-types-data (~> 3.2015)
177     mime-types-data (3.2016.0521)
178     mimemagic (0.3.2)
179     mini_mime (1.0.0)
180     mini_portile2 (2.3.0)
181     minitest (5.11.3)
182     msgpack (1.2.4)
183     multi_json (1.13.1)
184     multi_xml (0.6.0)
185     multipart-post (2.0.0)
186     nio4r (2.3.1)
187     nokogiri (1.8.3)
188       mini_portile2 (~> 2.3.0)
189     nokogumbo (1.5.0)
190       nokogiri
191     oauth (0.4.7)
192     oauth-plugin (0.5.1)
193       multi_json
194       oauth (~> 0.4.4)
195       oauth2 (>= 0.5.0)
196       rack
197     oauth2 (1.4.0)
198       faraday (>= 0.8, < 0.13)
199       jwt (~> 1.0)
200       multi_json (~> 1.3)
201       multi_xml (~> 0.5)
202       rack (>= 1.2, < 3)
203     omniauth (1.8.1)
204       hashie (>= 3.4.6, < 3.6.0)
205       rack (>= 1.6.2, < 3)
206     omniauth-facebook (5.0.0)
207       omniauth-oauth2 (~> 1.2)
208     omniauth-github (1.3.0)
209       omniauth (~> 1.5)
210       omniauth-oauth2 (>= 1.4.0, < 2.0)
211     omniauth-google-oauth2 (0.5.3)
212       jwt (>= 1.5)
213       omniauth (>= 1.1.1)
214       omniauth-oauth2 (>= 1.5)
215     omniauth-mediawiki (0.0.3)
216       jwt (~> 1.0)
217       omniauth-oauth (~> 1.0)
218     omniauth-oauth (1.1.0)
219       oauth
220       omniauth (~> 1.0)
221     omniauth-oauth2 (1.5.0)
222       oauth2 (~> 1.1)
223       omniauth (~> 1.2)
224     omniauth-openid (1.0.1)
225       omniauth (~> 1.0)
226       rack-openid (~> 1.3.1)
227     omniauth-windowslive (0.0.12)
228       multi_json (~> 1.12)
229       omniauth-oauth2 (~> 1.4)
230     openstreetmap-deadlock_retry (1.3.0)
231     paperclip (5.3.0)
232       activemodel (>= 4.2.0)
233       activesupport (>= 4.2.0)
234       mime-types
235       mimemagic (~> 0.3.0)
236       terrapin (~> 0.6.0)
237     parallel (1.12.1)
238     parser (2.5.1.0)
239       ast (~> 2.4.0)
240     pg (0.21.0)
241     poltergeist (1.18.1)
242       capybara (>= 2.1, < 4)
243       cliver (~> 0.3.1)
244       websocket-driver (>= 0.2.0)
245     powerpack (0.1.2)
246     progress (3.4.0)
247     psych (3.0.2)
248     public_suffix (3.0.2)
249     puma (3.11.4)
250     quad_tile (1.0.1)
251     r2 (0.2.7)
252     rack (2.0.5)
253     rack-cors (1.0.2)
254     rack-openid (1.3.1)
255       rack (>= 1.1.0)
256       ruby-openid (>= 2.1.8)
257     rack-test (1.0.0)
258       rack (>= 1.0, < 3)
259     rack-uri_sanitizer (0.0.2)
260     rails (5.2.0)
261       actioncable (= 5.2.0)
262       actionmailer (= 5.2.0)
263       actionpack (= 5.2.0)
264       actionview (= 5.2.0)
265       activejob (= 5.2.0)
266       activemodel (= 5.2.0)
267       activerecord (= 5.2.0)
268       activestorage (= 5.2.0)
269       activesupport (= 5.2.0)
270       bundler (>= 1.3.0)
271       railties (= 5.2.0)
272       sprockets-rails (>= 2.0.0)
273     rails-controller-testing (1.0.2)
274       actionpack (~> 5.x, >= 5.0.1)
275       actionview (~> 5.x, >= 5.0.1)
276       activesupport (~> 5.x)
277     rails-dom-testing (2.0.3)
278       activesupport (>= 4.2.0)
279       nokogiri (>= 1.6)
280     rails-html-sanitizer (1.0.4)
281       loofah (~> 2.2, >= 2.2.2)
282     rails-i18n (4.0.2)
283       i18n (~> 0.6)
284       rails (>= 4.0)
285     railties (5.2.0)
286       actionpack (= 5.2.0)
287       activesupport (= 5.2.0)
288       method_source
289       rake (>= 0.8.7)
290       thor (>= 0.18.1, < 2.0)
291     rainbow (3.0.0)
292     rake (12.3.1)
293     rb-fsevent (0.10.3)
294     rb-inotify (0.9.10)
295       ffi (>= 0.5.0, < 2)
296     record_tag_helper (1.0.0)
297       actionview (~> 5.x)
298     redcarpet (3.4.0)
299     ref (2.0.0)
300     request_store (1.4.1)
301       rack (>= 1.4)
302     rinku (2.0.4)
303     rotp (3.3.1)
304     rubocop (0.57.2)
305       jaro_winkler (~> 1.5.1)
306       parallel (~> 1.10)
307       parser (>= 2.5)
308       powerpack (~> 0.1)
309       rainbow (>= 2.2.2, < 4.0)
310       ruby-progressbar (~> 1.7)
311       unicode-display_width (~> 1.0, >= 1.0.1)
312     ruby-openid (2.7.0)
313     ruby-progressbar (1.9.0)
314     ruby_dep (1.5.0)
315     safe_yaml (1.0.4)
316     sanitize (4.6.5)
317       crass (~> 1.0.2)
318       nokogiri (>= 1.4.4)
319       nokogumbo (~> 1.4)
320     sass (3.5.6)
321       sass-listen (~> 4.0.0)
322     sass-listen (4.0.0)
323       rb-fsevent (~> 0.9, >= 0.9.4)
324       rb-inotify (~> 0.9, >= 0.9.7)
325     sass-rails (5.0.7)
326       railties (>= 4.0.0, < 6)
327       sass (~> 3.1)
328       sprockets (>= 2.8, < 4.0)
329       sprockets-rails (>= 2.0, < 4.0)
330       tilt (>= 1.1, < 3)
331     secure_headers (6.0.0)
332     simplecov (0.14.1)
333       docile (~> 1.1.0)
334       json (>= 1.8, < 3)
335       simplecov-html (~> 0.10.0)
336     simplecov-html (0.10.2)
337     sprockets (3.7.1)
338       concurrent-ruby (~> 1.0)
339       rack (> 1, < 3)
340     sprockets-rails (3.2.1)
341       actionpack (>= 4.0)
342       activesupport (>= 4.0)
343       sprockets (>= 3.0.0)
344     term-ansicolor (1.6.0)
345       tins (~> 1.0)
346     terrapin (0.6.0)
347       climate_control (>= 0.0.3, < 1.0)
348     therubyracer (0.12.3)
349       libv8 (~> 3.16.14.15)
350       ref
351     thor (0.19.4)
352     thread_safe (0.3.6)
353     tilt (2.0.8)
354     tins (1.16.3)
355     tzinfo (1.2.5)
356       thread_safe (~> 0.1)
357     uglifier (4.1.11)
358       execjs (>= 0.3.0, < 3)
359     unicode-display_width (1.4.0)
360     validates_email_format_of (1.6.3)
361       i18n
362     vendorer (0.1.16)
363     webmock (3.4.2)
364       addressable (>= 2.3.6)
365       crack (>= 0.3.2)
366       hashdiff
367     websocket-driver (0.7.0)
368       websocket-extensions (>= 0.1.0)
369     websocket-extensions (0.1.3)
370     xpath (3.1.0)
371       nokogiri (~> 1.8)
372
373 PLATFORMS
374   ruby
375
376 DEPENDENCIES
377   SystemTimer (>= 1.1.3)
378   aasm
379   actionpack-page_caching
380   annotate
381   autoprefixer-rails
382   better_errors
383   bigdecimal (~> 1.1.0)
384   binding_of_caller
385   bootsnap (>= 1.1.0)
386   canonical-rails
387   capybara (~> 2.13)
388   coffee-rails (~> 4.2)
389   composite_primary_keys (~> 11.0.0)
390   coveralls
391   dalli
392   dynamic_form
393   factory_bot_rails
394   faraday
395   geoip
396   htmlentities
397   http_accept_language (~> 2.0.0)
398   i18n-js (>= 3.0.0)
399   image_optim_rails
400   jquery-rails
401   jshint
402   json
403   jsonify-rails
404   kgio
405   libxml-ruby (>= 2.0.5)
406   listen
407   logstasher
408   minitest (~> 5.1)
409   oauth-plugin (>= 0.5.1)
410   omniauth
411   omniauth-facebook
412   omniauth-github
413   omniauth-google-oauth2 (>= 0.2.7)
414   omniauth-mediawiki (>= 0.0.3)
415   omniauth-openid
416   omniauth-windowslive
417   openstreetmap-deadlock_retry (>= 1.3.0)
418   paperclip (~> 5.2)
419   pg (~> 0.18)
420   poltergeist
421   psych
422   puma (~> 3.7)
423   quad_tile (~> 1.0.1)
424   r2 (~> 0.2.7)
425   rack-cors
426   rack-uri_sanitizer
427   rails (= 5.2.0)
428   rails-controller-testing
429   rails-i18n (~> 4.0.0)
430   record_tag_helper
431   redcarpet
432   rinku (>= 1.2.2)
433   rotp
434   rubocop
435   sanitize
436   sass-rails (~> 5.0)
437   secure_headers
438   uglifier (>= 1.3.0)
439   validates_email_format_of (>= 1.5.1)
440   vendorer
441   webmock
442
443 BUNDLED WITH
444    1.16.2