Stick with CPK 5.0.4 for now as later versions seem to fail
[rails.git] / Gemfile
1 # Gem source to use
2 source 'http://rubygems.org'
3
4 # Require rails
5 gem 'rails', '3.2.5'
6
7 # Require things which have moved to gems in ruby 1.9
8 gem 'bigdecimal', :platforms => :ruby_19
9
10 # Require the postgres database driver
11 gem 'pg'
12
13 # Load jquery support
14 gem 'jquery-rails'
15
16 # Load rails plugins
17 gem 'rails-i18n', ">= 0.6.3"
18 gem 'dynamic_form'
19 gem 'rinku', '>= 1.2.2', :require => 'rails_rinku'
20 gem 'openstreetmap-oauth-plugin', '>= 0.4.0.1', :require => 'oauth-plugin'
21 gem 'open_id_authentication', '>= 1.1.0'
22 gem 'validates_email_format_of', '>= 1.5.1'
23 gem 'composite_primary_keys', '= 5.0.4'
24 gem 'http_accept_language', '>= 1.0.2'
25 gem 'paperclip', '~> 2.0'
26 gem 'deadlock_retry', '>= 1.2.0'
27
28 # Markdown formatting support
29 gem 'redcarpet'
30
31 # Character conversion support for ruby 1.8
32 gem 'iconv', :platforms => :ruby_18
33
34 # Load libxml support for XML parsing and generation
35 gem 'libxml-ruby', '>= 2.0.5', :require => 'libxml'
36
37 # Use for HTML sanitisation
38 gem 'sanitize'
39 gem 'htmlentities'
40
41 # Load SystemTimer for implementing request timeouts
42 gem 'SystemTimer', '>= 1.1.3', :require => 'system_timer', :platforms => :ruby_18
43
44 # Load httpclient for SOAP support for Quova GeoIP queries
45 gem 'httpclient'
46
47 # Load memcache in case we are using it
48 gem 'memcached', '>= 1.4.1'
49
50 # Gems needed for running tests
51 group :test do
52   gem 'timecop'
53   gem 'minitest', :platforms => :ruby_19
54 end
55
56 # Gems needed for compiling assets
57 group :assets do
58   gem 'sass-rails', '~> 3.2.3'
59   gem 'coffee-rails', '~> 3.2.1'
60   gem 'uglifier', '>= 1.0.3'
61   gem 'therubyracer'
62 end