Fix small screen CSS rules that match on a body class
[rails.git] / Gemfile.lock
index a9102e5a1887c0b9fc10e668ded50de890ae715b..341e95ccfede061a02d8674fee71edf1c2b716aa 100644 (file)
 GEM
-  remote: http://rubygems.org/
+  remote: https://rubygems.org/
   specs:
     SystemTimer (1.2.3)
-    actionmailer (3.2.12)
-      actionpack (= 3.2.12)
-      mail (~> 2.4.4)
-    actionpack (3.2.12)
-      activemodel (= 3.2.12)
-      activesupport (= 3.2.12)
-      builder (~> 3.0.0)
+    actionmailer (4.2.3)
+      actionpack (= 4.2.3)
+      actionview (= 4.2.3)
+      activejob (= 4.2.3)
+      mail (~> 2.5, >= 2.5.4)
+      rails-dom-testing (~> 1.0, >= 1.0.5)
+    actionpack (4.2.3)
+      actionview (= 4.2.3)
+      activesupport (= 4.2.3)
+      rack (~> 1.6)
+      rack-test (~> 0.6.2)
+      rails-dom-testing (~> 1.0, >= 1.0.5)
+      rails-html-sanitizer (~> 1.0, >= 1.0.2)
+    actionpack-page_caching (1.0.2)
+      actionpack (>= 4.0.0, < 5)
+    actionview (4.2.3)
+      activesupport (= 4.2.3)
+      builder (~> 3.1)
       erubis (~> 2.7.0)
-      journey (~> 1.0.4)
-      rack (~> 1.4.5)
-      rack-cache (~> 1.2)
-      rack-test (~> 0.6.1)
-      sprockets (~> 2.2.1)
-    activemodel (3.2.12)
-      activesupport (= 3.2.12)
-      builder (~> 3.0.0)
-    activerecord (3.2.12)
-      activemodel (= 3.2.12)
-      activesupport (= 3.2.12)
-      arel (~> 3.0.2)
-      tzinfo (~> 0.3.29)
-    activeresource (3.2.12)
-      activemodel (= 3.2.12)
-      activesupport (= 3.2.12)
-    activesupport (3.2.12)
-      i18n (~> 0.6)
-      multi_json (~> 1.0)
-    arel (3.0.2)
+      rails-dom-testing (~> 1.0, >= 1.0.5)
+      rails-html-sanitizer (~> 1.0, >= 1.0.2)
+    activejob (4.2.3)
+      activesupport (= 4.2.3)
+      globalid (>= 0.3.0)
+    activemodel (4.2.3)
+      activesupport (= 4.2.3)
+      builder (~> 3.1)
+    activerecord (4.2.3)
+      activemodel (= 4.2.3)
+      activesupport (= 4.2.3)
+      arel (~> 6.0)
+    activesupport (4.2.3)
+      i18n (~> 0.7)
+      json (~> 1.7, >= 1.7.7)
+      minitest (~> 5.1)
+      thread_safe (~> 0.3, >= 0.3.4)
+      tzinfo (~> 1.1)
+    arel (6.0.2)
+    ast (2.0.0)
+    astrolabe (1.3.1)
+      parser (~> 2.2)
+    autoprefixer-rails (5.2.1.1)
+      execjs
+      json
     bigdecimal (1.1.0)
-    builder (3.0.4)
+    builder (3.2.2)
+    capybara (2.4.4)
+      mime-types (>= 1.16)
+      nokogiri (>= 1.3.3)
+      rack (>= 1.0.0)
+      rack-test (>= 0.5.4)
+      xpath (~> 2.0)
     climate_control (0.0.3)
       activesupport (>= 3.0)
-    cocaine (0.5.1)
+    cliver (0.3.2)
+    cocaine (0.5.7)
       climate_control (>= 0.0.3, < 1.0)
-    coffee-rails (3.2.2)
+    coffee-rails (4.1.0)
       coffee-script (>= 2.2.0)
-      railties (~> 3.2.0)
-    coffee-script (2.2.0)
+      railties (>= 4.0.0, < 5.0)
+    coffee-script (2.4.1)
       coffee-script-source
       execjs
-    coffee-script-source (1.4.0)
-    composite_primary_keys (5.0.12)
-      activerecord (~> 3.2.0, >= 3.2.9)
+    coffee-script-source (1.9.1.1)
+    colorize (0.7.7)
+    composite_primary_keys (8.1.0)
+      activerecord (~> 4.2.0)
+    coveralls (0.8.2)
+      json (~> 1.8)
+      rest-client (>= 1.6.8, < 2)
+      simplecov (~> 0.10.0)
+      term-ansicolor (~> 1.3)
+      thor (~> 0.19.1)
+    crass (1.0.2)
+    dalli (2.7.4)
     deadlock_retry (1.2.0)
+    docile (1.1.5)
+    domain_name (0.5.24)
+      unf (>= 0.0.5, < 1.0.0)
     dynamic_form (1.1.4)
-    ejs (1.1.1)
     erubis (2.7.0)
-    execjs (1.4.0)
-      multi_json (~> 1.0)
-    faraday (0.8.5)
-      multipart-post (~> 1.1)
-    hike (1.2.1)
-    htmlentities (4.3.1)
-    http_accept_language (1.0.2)
-    httpauth (0.2.0)
-    httpclient (2.3.2)
-    i18n (0.6.1)
-    i18n-js (3.0.0.rc3)
-      i18n
-    iconv (0.1)
-    journey (1.0.4)
-    jquery-rails (2.2.1)
-      railties (>= 3.0, < 5.0)
+    execjs (2.5.2)
+    faraday (0.9.1)
+      multipart-post (>= 1.2, < 3)
+    globalid (0.3.5)
+      activesupport (>= 4.1.0)
+    hashie (3.4.2)
+    hike (1.2.3)
+    htmlentities (4.3.4)
+    http-cookie (1.0.2)
+      domain_name (~> 0.5)
+    http_accept_language (2.0.5)
+    httpclient (2.6.0.1)
+    i18n (0.7.0)
+    i18n-js (3.0.0.rc11)
+      i18n (~> 0.6)
+    jquery-rails (4.0.4)
+      rails-dom-testing (~> 1.0)
+      railties (>= 4.2.0)
       thor (>= 0.14, < 2.0)
-    json (1.7.7)
-    jwt (0.1.5)
-      multi_json (>= 1.0)
-    libv8 (3.3.10.4)
-    libxml-ruby (2.5.0)
-    mail (2.4.4)
-      i18n (>= 0.4.0)
-      mime-types (~> 1.16)
-      treetop (~> 1.4.8)
-    memcached (1.5.0)
-    mime-types (1.21)
-    minitest (4.6.0)
-    multi_json (1.5.1)
-    multi_xml (0.5.3)
-    multipart-post (1.1.5)
-    nokogiri (1.5.6)
+    jshint (1.3.1)
+      execjs (>= 1.4.0)
+      multi_json (~> 1.0)
+      therubyracer (~> 0.12.1)
+    json (1.8.3)
+    jsonify (0.3.1)
+      multi_json (~> 1.0)
+    jsonify-rails (0.3.2)
+      actionpack
+      jsonify (< 0.4.0)
+    jwt (1.5.1)
+    kgio (2.9.3)
+    konacha (3.5.1)
+      actionpack (>= 3.1, < 5)
+      capybara
+      colorize
+      railties (>= 3.1, < 5)
+      sprockets (>= 2, < 4)
+      tilt
+    libv8 (3.16.14.11)
+    libxml-ruby (2.8.0)
+    logstash-event (1.2.02)
+    logstasher (0.6.5)
+      logstash-event (~> 1.2.0)
+      request_store
+    loofah (2.0.2)
+      nokogiri (>= 1.5.9)
+    mail (2.6.3)
+      mime-types (>= 1.16, < 3)
+    mime-types (2.6.1)
+    mimemagic (0.3.0)
+    mini_portile (0.6.2)
+    minitest (5.7.0)
+    multi_json (1.11.2)
+    multi_xml (0.5.5)
+    multipart-post (2.0.0)
+    netrc (0.10.3)
+    nokogiri (1.6.6.2)
+      mini_portile (~> 0.6.0)
+    nokogumbo (1.4.1)
+      nokogiri
     oauth (0.4.7)
-    oauth-plugin (0.4.1)
+    oauth-plugin (0.5.1)
       multi_json
       oauth (~> 0.4.4)
       oauth2 (>= 0.5.0)
       rack
-    oauth2 (0.9.0)
-      faraday (~> 0.8)
-      httpauth (~> 0.1)
-      jwt (~> 0.1.4)
-      multi_json (~> 1.0)
+    oauth2 (1.0.0)
+      faraday (>= 0.8, < 0.10)
+      jwt (~> 1.0)
+      multi_json (~> 1.3)
       multi_xml (~> 0.5)
       rack (~> 1.2)
-    open_id_authentication (1.1.0)
-      rack-openid (~> 1.3)
-    paperclip (2.8.0)
-      activerecord (>= 2.3.0)
-      activesupport (>= 2.3.2)
-      cocaine (>= 0.0.2)
+    omniauth (1.2.2)
+      hashie (>= 1.2, < 4)
+      rack (~> 1.0)
+    omniauth-facebook (2.0.1)
+      omniauth-oauth2 (~> 1.2)
+    omniauth-oauth2 (1.3.1)
+      oauth2 (~> 1.0)
+      omniauth (~> 1.2)
+    omniauth-openid (1.0.1)
+      omniauth (~> 1.0)
+      rack-openid (~> 1.3.1)
+    omniauth-windowslive (0.0.9)
+      multi_json (>= 1.0.3)
+      omniauth-oauth2 (~> 1.0)
+    openstreetmap-omniauth-google-oauth2 (0.2.6.1)
+      jwt (~> 1.0)
+      multi_json (~> 1.3)
+      omniauth (>= 1.1.1)
+      omniauth-oauth2 (>= 1.1.1)
+    paperclip (4.3.0)
+      activemodel (>= 3.2.0)
+      activesupport (>= 3.2.0)
+      cocaine (~> 0.5.5)
       mime-types
-    pg (0.14.1)
-    polyglot (0.3.3)
-    r2 (0.0.3)
-    rack (1.4.5)
-    rack-cache (1.2)
-      rack (>= 0.4)
-    rack-cors (0.2.7)
-      rack
+      mimemagic (= 0.3.0)
+    parser (2.2.2.6)
+      ast (>= 1.1, < 3.0)
+    pg (0.18.2)
+    poltergeist (1.6.0)
+      capybara (~> 2.1)
+      cliver (~> 0.3.1)
+      multi_json (~> 1.0)
+      websocket-driver (>= 0.2.0)
+    powerpack (0.1.1)
+    psych (2.0.13)
+    r2 (0.2.5)
+    rack (1.6.4)
+    rack-cors (0.4.0)
     rack-openid (1.3.1)
       rack (>= 1.1.0)
       ruby-openid (>= 2.1.8)
-    rack-ssl (1.3.3)
-      rack
-    rack-test (0.6.2)
+    rack-test (0.6.3)
       rack (>= 1.0)
-    rails (3.2.12)
-      actionmailer (= 3.2.12)
-      actionpack (= 3.2.12)
-      activerecord (= 3.2.12)
-      activeresource (= 3.2.12)
-      activesupport (= 3.2.12)
-      bundler (~> 1.0)
-      railties (= 3.2.12)
-    rails-i18n (0.7.2)
-      i18n (~> 0.5)
-    railties (3.2.12)
-      actionpack (= 3.2.12)
-      activesupport (= 3.2.12)
-      rack-ssl (~> 1.3.2)
+    rails (4.2.3)
+      actionmailer (= 4.2.3)
+      actionpack (= 4.2.3)
+      actionview (= 4.2.3)
+      activejob (= 4.2.3)
+      activemodel (= 4.2.3)
+      activerecord (= 4.2.3)
+      activesupport (= 4.2.3)
+      bundler (>= 1.3.0, < 2.0)
+      railties (= 4.2.3)
+      sprockets-rails
+    rails-deprecated_sanitizer (1.0.3)
+      activesupport (>= 4.2.0.alpha)
+    rails-dom-testing (1.0.6)
+      activesupport (>= 4.2.0.beta, < 5.0)
+      nokogiri (~> 1.6.0)
+      rails-deprecated_sanitizer (>= 1.0.1)
+    rails-html-sanitizer (1.0.2)
+      loofah (~> 2.0)
+    rails-i18n (4.0.4)
+      i18n (~> 0.6)
+      railties (~> 4.0)
+    railties (4.2.3)
+      actionpack (= 4.2.3)
+      activesupport (= 4.2.3)
       rake (>= 0.8.7)
-      rdoc (~> 3.4)
-      thor (>= 0.14.6, < 2.0)
-    rake (10.0.3)
-    rdoc (3.12.1)
-      json (~> 1.4)
-    redcarpet (2.2.2)
-    rinku (1.7.2)
-    ruby-openid (2.2.2)
-    sanitize (2.0.3)
-      nokogiri (>= 1.4.4, < 1.6)
-    sass (3.2.5)
-    sass-rails (3.2.6)
-      railties (~> 3.2.0)
-      sass (>= 3.1.10)
-      tilt (~> 1.3)
-    sprockets (2.2.2)
+      thor (>= 0.18.1, < 2.0)
+    rainbow (2.0.0)
+    rake (10.4.2)
+    redcarpet (3.3.2)
+    ref (2.0.0)
+    request_store (1.2.0)
+    rest-client (1.8.0)
+      http-cookie (>= 1.0.2, < 2.0)
+      mime-types (>= 1.16, < 3.0)
+      netrc (~> 0.7)
+    rinku (1.7.3)
+    rubocop (0.32.1)
+      astrolabe (~> 1.3)
+      parser (>= 2.2.2.5, < 3.0)
+      powerpack (~> 0.1)
+      rainbow (>= 1.99.1, < 3.0)
+      ruby-progressbar (~> 1.4)
+    ruby-openid (2.7.0)
+    ruby-progressbar (1.7.5)
+    sanitize (4.0.0)
+      crass (~> 1.0.2)
+      nokogiri (>= 1.4.4)
+      nokogumbo (= 1.4.1)
+    sass (3.4.16)
+    sass-rails (5.0.3)
+      railties (>= 4.0.0, < 5.0)
+      sass (~> 3.1)
+      sprockets (>= 2.8, < 4.0)
+      sprockets-rails (>= 2.0, < 4.0)
+      tilt (~> 1.1)
+    simplecov (0.10.0)
+      docile (~> 1.1.0)
+      json (~> 1.8)
+      simplecov-html (~> 0.10.0)
+    simplecov-html (0.10.0)
+    soap4r-ruby1.9 (2.0.5)
+    sprockets (2.12.4)
       hike (~> 1.2)
       multi_json (~> 1.0)
       rack (~> 1.0)
       tilt (~> 1.1, != 1.3.0)
-    therubyracer (0.10.2)
-      libv8 (~> 3.3.10)
-    thor (0.17.0)
-    tilt (1.3.3)
-    timecop (0.5.9.2)
-    treetop (1.4.12)
-      polyglot
-      polyglot (>= 0.3.1)
-    tzinfo (0.3.35)
-    uglifier (1.3.0)
+    sprockets-rails (2.3.2)
+      actionpack (>= 3.0)
+      activesupport (>= 3.0)
+      sprockets (>= 2.8, < 4.0)
+    term-ansicolor (1.3.2)
+      tins (~> 1.0)
+    therubyracer (0.12.2)
+      libv8 (~> 3.16.14.0)
+      ref
+    thor (0.19.1)
+    thread_safe (0.3.5)
+    tilt (1.4.1)
+    timecop (0.7.4)
+    tins (1.5.4)
+    tzinfo (1.2.2)
+      thread_safe (~> 0.1)
+    uglifier (2.7.1)
       execjs (>= 0.3.0)
-      multi_json (~> 1.0, >= 1.0.2)
-    validates_email_format_of (1.5.3)
+      json (>= 1.8.0)
+    unf (0.1.4)
+      unf_ext
+    unf_ext (0.0.7.1)
+    validates_email_format_of (1.6.2)
+      i18n
+    vendorer (0.1.16)
+    websocket-driver (0.6.2)
+      websocket-extensions (>= 0.1.0)
+    websocket-extensions (0.1.2)
+    xpath (2.0.0)
+      nokogiri (~> 1.3)
 
 PLATFORMS
   ruby
 
 DEPENDENCIES
   SystemTimer (>= 1.1.3)
-  bigdecimal
-  coffee-rails (~> 3.2.1)
-  composite_primary_keys (>= 5.0.10)
+  actionpack-page_caching
+  autoprefixer-rails
+  bigdecimal (~> 1.1.0)
+  coffee-rails (~> 4.1.0)
+  composite_primary_keys (~> 8.1.0)
+  coveralls
+  dalli
   deadlock_retry (>= 1.2.0)
   dynamic_form
-  ejs
+  faraday
   htmlentities
-  http_accept_language (>= 1.0.2)
+  http_accept_language (~> 2.0.0)
   httpclient
-  i18n-js (>= 3.0.0.rc2)
-  iconv
+  i18n-js (>= 3.0.0.rc10)
   jquery-rails
+  jshint
+  json
+  jsonify-rails
+  kgio
+  konacha
   libxml-ruby (>= 2.0.5)
-  memcached (>= 1.4.1)
-  minitest
-  oauth-plugin (>= 0.4.1)
-  open_id_authentication (>= 1.1.0)
-  paperclip (~> 2.0)
+  logstasher
+  minitest (~> 5.1)
+  oauth-plugin (>= 0.5.1)
+  omniauth
+  omniauth-facebook
+  omniauth-openid
+  omniauth-windowslive
+  openstreetmap-omniauth-google-oauth2 (>= 0.2.6.1)
+  paperclip (~> 4.0)
   pg
+  poltergeist
+  psych
   r2
   rack-cors
-  rails (= 3.2.12)
-  rails-i18n (>= 0.6.3)
+  rails (= 4.2.3)
+  rails-i18n (~> 4.0.0)
   redcarpet
   rinku (>= 1.2.2)
-  ruby-openid (>= 2.2.0)
+  rubocop
   sanitize
-  sass-rails (~> 3.2.3)
-  therubyracer (~> 0.10.2)
+  sass-rails (~> 5.0)
+  soap4r-ruby1.9
+  sprockets (~> 2.12.3)
   timecop
-  uglifier (>= 1.0.3)
+  uglifier (>= 1.3.0)
   validates_email_format_of (>= 1.5.1)
+  vendorer