Improve the unsaved edits warning for Potlatch 2
authorTom Hughes <tom@compton.nu>
Tue, 30 Nov 2010 21:12:21 +0000 (21:12 +0000)
committerTom Hughes <tom@compton.nu>
Tue, 30 Nov 2010 21:12:21 +0000 (21:12 +0000)
app/views/site/_potlatch2.html.erb
config/locales/en.yml

index 8256540..cda423e 100644 (file)
@@ -14,7 +14,7 @@
   
   window.onbeforeunload=function() {
     if (!changesaved) {
-      return '<%= escape_javascript(t('site.edit.potlatch_unsaved_changes')) %>';
+      return '<%= escape_javascript(t('site.edit.potlatch2_unsaved_changes')) %>';
     }
   }
 
index beccc22..36ba2db 100644 (file)
@@ -1248,6 +1248,7 @@ en:
       anon_edits_link_text: "Find out why this is the case."
       flash_player_required: 'You need a Flash player to use Potlatch, the OpenStreetMap Flash editor. You can <a href="http://www.adobe.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash">download Flash Player from Adobe.com</a>. <a href="http://wiki.openstreetmap.org/wiki/Editing">Several other options</a> are also available for editing OpenStreetMap.'
       potlatch_unsaved_changes: "You have unsaved changes. (To save in Potlatch, you should deselect the current way or point, if editing in live mode, or click save if you have a save button.)"
+      potlatch2_unsaved_changes: "You have unsaved changes. (To save in Potlatch 2, you should click save.)"
       no_iframe_support: "Your browser doesn't support HTML iframes, which are necessary for this feature."
     sidebar:
       search_results: Search Results