api06: Fix OSM::APIVersionMismatchError.render_opts
authorGabriel Ebner <gabriel@svn.openstreetmap.org>
Tue, 13 May 2008 12:32:43 +0000 (12:32 +0000)
committerGabriel Ebner <gabriel@svn.openstreetmap.org>
Tue, 13 May 2008 12:32:43 +0000 (12:32 +0000)
lib/osm.rb

index 38053e1..c038ab2 100644 (file)
@@ -42,8 +42,8 @@ module OSM
     attr_reader :provided, :latest
 
     def render_opts
-      { :text => "Version mismatch: Provided " + ex.provided.to_s +
-       ", server had: " + ex.latest.to_s, :status => :bad_request }
+      { :text => "Version mismatch: Provided " + provided.to_s +
+       ", server had: " + latest.to_s, :status => :bad_request }
     end
   end