Require a specific version of the oauth plugin
authorTom Hughes <tom@compton.nu>
Fri, 24 Sep 2010 10:02:41 +0000 (11:02 +0100)
committerTom Hughes <tom@compton.nu>
Fri, 24 Sep 2010 10:02:41 +0000 (11:02 +0100)
It looks likely that the API  will change in future versions of
the oauth plugin, so require a known working version for now.

config/environment.rb

index 7e550ca9f42a07f7ccfa62475053ae1d70dbc9df..6d6c952fb0143811374acf7b1862fa25cc4bfa59 100644 (file)
@@ -21,7 +21,7 @@ Rails::Initializer.run do |config|
   config.gem 'libxml-ruby', :version => '>= 1.1.1', :lib => 'libxml'
   config.gem 'rmagick', :lib => 'RMagick'
   config.gem 'oauth', :version => '>= 0.4.3'
-  config.gem 'oauth-plugin', :version => '>= 0.3.14'
+  config.gem 'oauth-plugin', :version => '0.3.14'
   config.gem 'httpclient'
   config.gem 'SystemTimer', :version => '>= 1.1.3', :lib => 'system_timer'
   config.gem 'sanitize'