Monkey patch postgres adapter for postgres 9 support