Require ruby-openid 2.2.0 or later for ruby 1.9 support
authorTom Hughes <tom@compton.nu>
Sat, 7 Jul 2012 19:40:04 +0000 (20:40 +0100)
committerTom Hughes <tom@compton.nu>
Sat, 7 Jul 2012 19:40:04 +0000 (20:40 +0100)
Gemfile
Gemfile.lock

diff --git a/Gemfile b/Gemfile
index 7109b12368f97324f1e82df298c98da79ce0545e..3e3ab14de75bee7c16ca05bc61c1cde8464231a8 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -25,6 +25,9 @@ gem 'http_accept_language', '>= 1.0.2'
 gem 'paperclip', '~> 2.0'
 gem 'deadlock_retry', '>= 1.2.0'
 
+# We need ruby-openid 2.2.0 or later for ruby 1.9 support
+gem 'ruby-openid', '>= 2.2.0'
+
 # Browser detection support
 gem 'browser'
 
index 35b50a361d624e23fe539e24843b3e7cad7a1fcf..07f3b5beecaaa13bcceb052ed6054f7f3a186eb7 100644 (file)
@@ -115,7 +115,7 @@ GEM
       activesupport (= 3.2.6)
       bundler (~> 1.0)
       railties (= 3.2.6)
-    rails-i18n (0.6.4)
+    rails-i18n (0.6.5)
       i18n (~> 0.5)
     railties (3.2.6)
       actionpack (= 3.2.6)
@@ -129,7 +129,7 @@ GEM
       json (~> 1.4)
     redcarpet (2.1.1)
     rinku (1.5.1)
-    ruby-openid (2.1.8)
+    ruby-openid (2.2.0)
     sanitize (2.0.3)
       nokogiri (>= 1.4.4, < 1.6)
     sass (3.1.20)
@@ -182,6 +182,7 @@ DEPENDENCIES
   rails-i18n (>= 0.6.3)
   redcarpet
   rinku (>= 1.2.2)
+  ruby-openid (>= 2.2.0)
   sanitize
   sass-rails (~> 3.2.3)
   therubyracer