Remove compatibility code for old versions of rails