Get rid of pre 14.04 compatibility that is no longer needed