Update Potlatch 2 to r24317 build